
Step-by-step guide to dubbing (ADR) in Audacity 

 

Step 1: Starting out 

● Open the .mp4 movie file you want to dub (open as in any other program: File > Open) 

● The .mp4 file can already have hard coded subtitles 

● Remember that Audacity is an audio editor: it cannot display video so the video won’t be                
affected in any way (this doesn’t matter because we are usually only concerned with              
synchronizing our dubs with the voices in the clip)  

● At this point you should save your project! Even though we haven’t done anything              
yet it’s a good habit to get into: go to File > Save Project As … and give your project a                     
sensible name in a folder where you can find it (i.e. be organized!) 

Step 2: Identifying utterances to dub 

● Remember that waveforms (the spiky blue blobs/lines) are the visual representation of            
the audio track: there are two of them because the audio is in stereo (Left and Right): 

● Zoom into a region using     
the magnifying glasses in    
the toolbar: because your    
are doing NLE you don’t     
have to start at the     
beginning of the clip!  
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● Tip: the zoom function will always focus on the region around the cursor (the vertical               
line), but you can always scroll back and forth using the scroll bar at the bottom (as you                  
find in many other programs) 

● Most of your work will be done using the ‘selection tool’, which looks             
like the one in a word processor (although it will be found in different              
places, depending on how the toolbars are arranged in your version of            
Audacity)  

● Zoom in until you can see some blip/blob like sections: these usually but not always               
represent speech - especially if there is music or other noise in the soundtrack: 
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● Using the ‘drag and highlight’ technique (as you would with text in a word processor) and                
listen to that region by pressing play (when you have a region selected Audacity will only                
play what’s in that region): this is a way of just checking out what’s there, and gives you                  
a way to identify the utterances you want to dub: 

 

 

● Let’s say the you have verified that these three ‘speech blobs’ are three utterances you               
want to dub (this is a fishing expedition - you get better at finding them with practice!) 
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Step 3: Loop rehearsing (entrainment), dubbing and Vocal Removal 

● Highlight the first utterance you want to dub by using the waveform as a visual reference                
(and zoom further if necessary): 
 

 

● Keep hitting play and adjusting the highlighted region until you find a region that has all                
of the speech (not cutting anything off) and has a natural ‘rhythm’ to rehearse the               
dubbing - this takes some trial and error 

● Tip: the space bar acts as a stop/start button (which saves you all of the mouse clicks on                  
the actual play button) 

● Rehearse the clip by looping the highlighted region: the looping function can be found              
under Transport > Loop Play 

● Loop rehearse until your speech matches the target speech (it usually only takes a few               
loops for entrainment to kick in): be sure to mimic the timing (duration), intonation              
and other vocal characteristics of the target speech as closely as possibly 
  

● When you feel confident, hit the record button        and ‘perform’ the utterance 

● This is the part that can take a bit of getting used to - it really is just trial and error at first                       
- remember you can try it as many times as you need! 
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http://en.wikipedia.org/wiki/Entrainment_(biomusicology)


● This will automatically create another audio track immediately below the original audio            
track  1

● The recording will also automatically stop at the end of the highlighted region 

 

● Note that you will likely record a mono track, which means there will be only one                
waveform in the newly created dub track -        
this should be ok for most purposes, but        
stereo dubbing is also possible (and will       
happen automatically if the computer     
knows you are using a stereo mic 

● Go back, listen and evaluate the results: if        
you want to re-do it, simply delete the dub         
track by clicking on the ‘x’ in the top left corner of the track 

1 You may need to change a setting under Preference > Recording: make sure the box for “Always record 
on a new track” is checked. (Mac computers seem to do this auromatically.) 
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● Tip: it often helps to have someone else listen to the dub (as our opinions can get                 
‘muddy’ from all of the repetition) 

 

● Once you are satisfied with the dub you should apply the Vocal Removal effect to the                
original audio track: under the Effect menu go all the way down near the bottom of the                 
list of effects to Vocal Removal and select (another dialogue window will open up asking               
for some settings to be made - simply chose OK for now) 

● Note: do not adjust the regions after the dub is complete! When you record your dub                
the highlighted region stays in place - this is important, as we want to apply the vocal                 
remover to only that region we’re dubbing (as the vocal remover can degrade the original               
audio sometimes) 

● The vocal remover is applied - you can see this visually in how the waveform for that                 
region ‘flattens’ (sometime by quite a lot): 

 

● At this point you should save your project! You should get in the habit of doing                
this after every major edit (just hit CTRL S) 

● Remember again: if you run into any problems or you lose control of the situation you                
can undo your edits right up until you last opened Audacity  
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● Repeat all of the steps above for every utterance you want to dub and remember               
that every new dub you make adds an extra track below: 

 

● Note how the waveform in the original track has been ‘flattened’ from successive             
applications of the vocal remover (compare with the other screencaps above) 

● Go back and evaluate the results from dubbing this group of utterances: play the whole               
thing through and check for matching levels and quality etc. 

● Tip:  do all of your dubbing in one session (if possible) to ensure audio consistency 

● If you’re happy with the results you should save your project! 
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Step 4: Partial Mixdown 

● After dubbing about 4 or five tracks Audacity can look a little busy vertically: we can                
apply a partial mixdown  to ‘combine’ the three tracks into a single track 

● Highlight the waveforms across the tracks: this is done by clicking, dragging and             
highlighting the waveform data: 

 

● Then from the menu Tracks select Mix and Render to New Track 
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● This will create another track immediately below with the audio of all of the selected               
tracks above mixed down  to a single track: 

 

● Delete the three separate tracks (by using the ‘x’ in the corner), and the new mixed down                 
track will move up - saving a lot of space 

● Note: mixing down is not necessary if you don’t mind scrolling vertically all the time, as                
mixing down does not affect the quality of the audio (although sometimes the levels can               
change slightly) 

Step 5: other editing 

● Other than the vocal reduction do not make any other edits to the original stereo audio                
track: remember that it has been previously mastered when the show was produced (all              
of the mixing, volume, equalization, effects, etc.) and does not need changing (also,             
deleting or inserting any material in the original audio would desynchronize everything) 

● You might want to raise or lower the volume of your dub tracks - there are a couple of                   
things to consider, and options to go with them: 

○ If the volume is too low try re-recording your voice          
with either increased mic input, or positioning       
yourself closer to the mic (or both) 
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○ If it’s not possible to record, then you can use an effect to adjust the volume                
either way: first highlight only the portion that needs adjusting, then from the             
Effect menu select the Bass and Treble effect - try some different adjustments             
and test with the Preview function 

○ Remember that you want to find the best match in volume, bass and treble with               
the original voice track 

● You might like your performance but find that it begins a little too             
soon or late in relation to the original voice: you can actually ‘slide’             
the position of the recorded audio using the Time Shift Tool, which            
uses the ‘click, hold, and drag’ technique: 

 

REPEAT STEPS 2 THROUGH 5 until you’ve added all of your dubs… 

… and remember to always frequently save your project! 

 

Step 6: Final Render 

● Once you have listened very carefully to the whole clip, checking for levels and              
synchronization, you are ready to do a final render (which is the A/V term for exporting) 

● Under the File menu select Export Audio…  

● The default format is .wav, which we will use: the .wav format is an uncompressed               
format - ideal as it does not affect the audio quality and can be read in almost any player                   
(the drawback is that the files can get very large) 

● Choose a sensible name for your file and save 

● Another dialogue box should appear asking you to enter in metadata: we suggest you do               
this, as it is a very good way to keep track of the details and history of your file, and                    
makes it easy to search for if you misplace it (the fields are self-explanatory) 

● Then click Save/OK 

● In another program (like Movie Maker or iMovie) we will use this file to replace the                
original audio file in your clip 
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Bonus: a useful feature 

● You can add a ‘Label Track’ to accompany your dubs (or the original audio) - a useful 
feature for dubbing  

● Once you have imported your original audio clip go to the menu Tracks > Add New > 
Label Track (do this before you’ve added any dub tracks): this will insert the Label track 
immediately below: 

 

 

● Using the Select Tool (see above) simply click on the Label Track the position you want                
the text to be associated with (this would probably be the same place as the beginning of                 
the region you plan to dub) 

● The start typing: the text will appear where you placed the cursor (the line that goes                
through the track) 
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● When you are finished entering the text (perhaps the translation) hit Enter and then it               
turns blue-ish: 

 

● Anytime you want to edit the text, just double click on the box and start editing again 

● Anytime you want to delete a label, just highlight the whole label (see above) with the                
text tool and press ‘delete’ 
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● Click on the beginning of the next speech ‘blobs’ and type the text associated with them                
- we’ve done a few in a row: 

 

● There is another feature where you can click and drag those ‘handles’ to cover a region 
for the individual texts, but it’s not necessary: this is really just a guide (which is a hack of 
the labelling function in Audacity) 

● Don’t worry about the labels ever overlapping: there is an automatic text box respacing 
function if they collide 

● You can add as many Label Tracks as you like 
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